Scheduled maintenance
Resolved
Feb 05 at 04:37am WIB
The scheduled maintenance has been completed. Thank you for your patience!
Affected services
Updated
Feb 05 at 02:15am WIB
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Affected services
Created
Feb 05 at 02:00am WIB
PT. Kimu Andalan Nusantara ill be performing routine maintenance on Feb 05 starting at 02:00 (UTC+7). You may not be able to access barangkulakan.com for a short period of time, but we’ll have things back up and running as soon as possible to minimize disruption to you.
Affected services